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1.0 - Design of the Instantaneous Z Score Normative Database 

 The central concept is the use of real-time Z scores to help guide or “re-tune” 

the EEG resonant frequencies and network patterns toward improved regulation of 

complex neural network systems using standard EEG biofeedback methods.  That is, 

the goal is to not reinforce extreme instantaneous Z scores representing brief moments 

of ‘chaos’ or dysregulation.   Instead reinforce periods of stability by reinforcing 

instantaneous Z scores that are moving in the direction of the center of a normal 

population or Z = 0.  This is a general mathematical process only if the EEG is 

transformed to approximate a Gaussian distribution and the measures are from the same 

universe of measures.   For example, Z scores are invalid if an apple is used as the 

standard for an orange even if they are both Gaussian.    

The majority of cortical pyramidal neurons resonate at specific center 

frequencies depending on the membrane potential and ionic conductances and behave 

like “band pass” filters that gate action potentials.   The pyramidal neuron resonances 

wax and wane and exhibit rhythmic bursts and periods of asynchrony in a non-Gaussian 

distribution as a function of time.   It is necessary to mathematically transform EEG 

digital data to approximate a Gaussian in shape and then the EEG normative database 

can be cross-validated and estimates of error can be made.   Z score biofeedback using 

the target of reinforcing toward of Z = 0 with respect to the center of an age matched 

group of healthy individuals is designed to reinforce increased information processing 

in networks of the brain.  The real-time EEG Z score was conceived in 1994 and 

created in 2002 and started with the University of Maryland normative database of   

“normal” subjects (N = 625).  An additional group of clinically healthy adult subjects 

(22 to 55) were added to the normative database using the Deymed amplifier.   

Standard equilibration of the amplifier frequency and gain characteristics was used to 

exactly match the Deymed amplifier to the University of Maryland amplifiers.   The  

normative database includes clinical selection criteria, age range (2 months to 82 

years), cross-validation tests, demographics, and other details of the Z score normative 

database have been published and are recommended reading for those interested in 

deeper details than is briefly reviewed in this document (see Thatcher, 1998a; 1998b; 

2001; 200; Thatcher and Lubar, 2008).   

The real-time Z score biofeedback method is called “Z Tunes” (ZT) in 

recognition of the neurophysiological linkage to resonant cortical pyramidal neurons 
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that operate by reinforcing a negative slope of outliers over a 10 second history in order 

to reinforce instantaneous brain states exhibiting increased stability in the direction of Z 

= 0.   

 

Four Basic Concepts used in the Design of Real-Time Z Scores 
 

1.1- Use of Gaussian Probabilities to Identify “De-Regulation” in the Brain 

The central idea of the instantaneous Z score is the application of the 

mathematical Gaussian curve or ‘Bell Shaped’ curve by which probabilities can be 

estimated using the auto and cross-spectrum of the electroencephalogram (EEG) in 

order to identify brain regions that are de-regulated and depart from expected values.   

Linkage of symptoms and complaints to functional localization in the brain is best 

achieved by the use of a minimum of 19 channel EEG evaluation so that current source 

density and LORETA source localization can be computed.   Once the linkage is made, 

then an individualized Z score protocol can be devised.    However, in order to make a 

linkage to symptoms an accurate statistical inference must be made using the Gaussian 

distribution.  The Gaussian distribution is a fundamental distribution that is used 

throughout science, for example, the Schrodinger wave equation in Quantum 

mechanics uses the Gaussian distribution as basis functions (Robinett, 1997).  The 

application of the EEG to the concept of the Gaussian distribution requires the use of 

standard mathematical transforms by which all statistical distributions can be 

transformed to a Gaussian distribution (Box and Cox, 1964).   In the case of the EEG, 

transforms such as the square root, cube root; log10, Box-Cox, etc.  are applied to the 

power spectrum of the digital time series in order to approximate a normal distribution 

(Gasser, et al, 1988a; 1988b; John et al, 1987; 1988, Duffy et al, 1994; Thatcher et al, 

2003; 2005a; 2005b).     The choice of the exact transform depends on the accuracy of 

the approximate match to a Gaussian distribution.   The fact that accuracies of 95% to 

99% match to a Gaussian are commonly published in the EEG literature encouraged 

Thatcher and colleaques to develop and test the Z score biofeedback program in the 

first place. 
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Fig. 1 – Example of Gaussian distributions of the Neuroguide “static” normative database.  The 

distribution is subjects over age.   From Thatcher et al, 2003. 
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Fig. 2-  Example of the distribution of instantaneous absolute values before and after a 

transform is applied to approximate Gaussian.   If no transform is used then the 

instantaneous Z scores are totally invalid and should not be used. 

 

 

 

1.2 – Sampling from the same population of measures of the human brain 

 

The second design concept is the application of the Gaussian distribution to 

averaged “instantaneous” time domain spectral measures from groups of normal 

subjects and then to cross-validate the means and standard deviations for each subject 

for each instant of time with respect to the measurement (Thatcher, 1998a; 1998b, 

2000a; 2000b).    The cross-validation is directly related to the mean and variance of the 

distribution from which the same samples are obtained  (Thatcher et al, 2003; 2005a; 

2005b).  This includes the physiological basis for the measures which must be the same 

because spatial and temporal localization validation is sufficient to prove validity.   

However, in order to achieve a representative sample of Z scores then the variables 

must be drawn from the same physiological population and be in agreement with 

respect to frequency and location.    Over the last twenty five years, the NYU and ANI 

normative databases have been repeatedly and independently cross-validated and are 

used world wide in many institutions and serve as a historical reference in the history of 

qEEG normative databases (see Thatcher and Lubar, 2008 and brainmaster independent 

comparisons at: http://www.brainm.com/kb/entry/525/ ) 
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).    Because of the 25 year history of high cross-validation the NYU and ANI databases 

in the “static” FFT domain then when used in the instantaneous domain they must also 

cross-validate between ANI and NYU.   Testing the foundations and examining the 

statistics is a crucial part of this process and full disclosure of equations and procedures 

allows for independent replication and validation in the future.   The good news is that a 

recent implementation of the NYU norms in the time domain matches the ANI time 

domain norms by a linear factor and appears to provide acceptable cross-validation (8% 

error) (http://www.brainm.com/kb/entry/525/ ). 

 In the case of the Fast Fourier Transform (FFT) there is a single spectral value 

for each subject and power at each frequency is computed over a one to several minute 

period and, therefore, there is only between subject variance in “static” qEEG 

normative databases that use non-instantaneous analyses such as the FFT “static” 

norms, i.e., the average of subjects over an age range.   Instantaneous or JTFA raw 

digital values differ from the FFT by being measures of the “instantaneous” state of the 

brain as defined by the center frequency and band width of the JTFA time/frequency 

transform.  In contrast, the FFT estimates the average spectral value over a period of 

time (e.g., 1 to 2 minutes) to produce a single value that is then added across subjects in 

a given age range.  The sample size is usually around 30 to 70 subjects in an age group 

and not tens of thousands of instantaneous JTFA values with variance as a function of 

age. 

The FFT and JTFA measure the same physiological processes in a statistically 

different manner and these two methods are essentially identical to each other when 

using large sample sizes and no FFT windowing.    Nonetheless, an important 

difference is that the average spectral values produced by a FFT involve different 

mathematical procedures and require windowing.  Therefore, the means are slightly 

different.  Also, the variance is larger with the instantaneous JTFA than the distribution 

over age as with the FFT.    For example, the FFT is calculated over an entire epoch of 

time (e.g., 1 or 2 seconds, etc) and must use windowing to prevent discontinuities in the 

computation and is noisy with low degrees of freedom.   In contrast, JTFA methods 

compute spectral values at each instant of time, do not involve windowing, have higher 

degrees of freedom and a different non-Gaussain distribution than the FFT average over 

an age range.    

Figure 3 is an example of the large and dramatic differences between the FFT 

and the Instantaneous spectrum over a two second period of time.  The mismatch 

occurs in all frequencies. Also, the FFT requires windowing in order to eliminate 

discontinuities at the boundary of the epoch which produces ringing and false 

frequencies.    Figure 3 top is the FFT computed over the 1
st
  two seconds of the 

Neuroguide demo.   Note the low degrees of freedom and noisy nature of the FFT.   

Figure 3 bottom is the JTFA over the same 2 second epoch of time and demonstrates a 

different measure set.    Nonetheless, if one sums over the entire epoch then the 

statistical degrees of freedom between the FFT and JTFA more closely match and both 

methods produce approximately the same, but not identical values due to the FFT 

windowing. 
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Fig. 3- Top is the FFT absolute power spectrum over the 1

st
 2 seconds of EEG and the 

bottom is the JTFA absolute power spectrum in the theta frequency band (4 - 8 Hz) 

over the same 2 seconds of EEG data.   This figure shows the dramatic difference 

between the FFT and the JTFA at low degrees of freedom.   The FFT requires 

windowing whereas the JTFA does not require windowing which results in slight 

differences in the total power measurements.   Nonetheless, at high degrees of freedom 

then the JTFA and FFT converge to very similar values, but not identical values.  The 

use of the FFT mean to calculate instantaneous Z scores is not optimal and presents 

scaling problems because of different mean values.  The simple computation is JTFA 

means to calculate JTFA Z scores and FFT means to calculate FFT Z scores.   As 

shown in figures 4 & 5, there are slight differences between the FFT and JTFA when 

testing with mathematically ideal sine waves.  

 

Here is an exercise to compare FFT vs JTFA values using calibration sine 

waves with the NeuroGuide signal generator program. 

 

1- Click File > Open > Signal Generator 

2- Double click 10 Hz and type 10 to produce a 10 uV peak-to-peak sine wave  

3- Click OK and in Neuroguide click Edit > Select All 

4- Click View > Dynamic JTFA and select abs, power, average abs. power and 

click Apply 
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5- Note that the alpha band shows 49.98 which is also produced 

mathematically by squaring 7.07 RMS – This is the JTFA spectral test 

6- For the FFT, deselect the JTFA and click > Report Selections 

7- Select Spectral Values > Absolute Power and Raw Scores & OK 

8- Click Report > Report Generate and note that  

 

 Figure 4 is a diagram to illustrate the relationship between the mean of a FFT 

based normative database versus the mean of an “instantaneous” or Joint Time 

Frequency Analysis (JTFA) database. 

 

 
Fig. 4 – Top illustrates a 10 Hz & 10 uV sine wave.  The expected power is the RMS 

value of the sine wave which = 7.07 ^ 2 = 49.9849 uV^2.    The middle trace is a 10 Hz, 

10 uV sine wave produced by the Neuroguide signal generator.   Click View > JTFA > 

Absolute Power and select average of Absolute Values which produces 49.98 uV^2 

which is exactly as mathematically predicted 

 

 

 This is good news because it shows a convergence or cross-validation of the 

same exact underlying EEG linearly scaled differently.    However, this is not trivial in 

the statistics of sampling theory where one samples from two populations that have 

highly correlated and linearly scaled for each frequency.     If a scaling factor is used to 

equate the JTFA and FFT absolute values then it is important to describe the procedure 

and method of linear scaling.   If no FFT windowing is used then this too should be 
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stated.   Without windowing then discontinuities at the beginning and end of the epoch 

will produce ringing and false frequencies.    Neuroguide uses a cosine taper to window 

the FFT.   A simpler approach is to use the instantaneous means and standard 

deviations from the outset and then there is no question that in fact apples are compared 

to apples and oranges are compared to oranges.   The between subject variance using 

instantaneous means and standard deviations to calculate instantaneous Z scores is valid 

although with significantly lower degrees of freedom.   ANI is currently comparing the 

instantaneous Z scores computed with and without within session variance and if the 

values are stable and valid than this method may be implemented so that the absolute 

value of Z scores more closely matches the static FFT Z scoresThis will result in larger 

Z scores that are closer to the mean of the FFT norms without relying on “static” age 

regressed means.   The use of the instantaneous means is not more computationally 

taxing and it avoids the need to use FFT means and standard deviations from age 

regression norms.    

 

 
Fig. 5- Top illustrates a 10 Hz & 10 uV sine wave.  The expected power is the RMS 

value of the sine wave which = 7.07 ^ 2 = 49.9849 uV^2.    The middle trace is the FFT 

power spectrum showing 43.03143 uV^2 or 6.953 uV^2 less power than the 

mathematical ideal and the JTFA.   The reason for the difference is because the FFT 

requires windowing (cosine taper) otherwise there will be discontinuities and ringing or 

non-real frequencies in the spectra.    Bottom is the same 10 Hz, 10 uV peak-to-peak as 

in figure 4 as produced by the same signal generator.    
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1.4 – Simplification and Standardization 

The third design concept is simplification and standardization of EEG 

biofeedback by the application of basic science.  Simplification is achieved by the use 

of a single metric, namely, the metric of the “Z Score” for widely diverse measures 

such as power, coherence and phase delays.  Standardization is also achieved by EEG 

amplifier matching of the frequency response of the normative database amplifiers to 

the frequency characteristics of the EEG amplifiers used to acquire a comparison 

subject’s EEG time series.    

 

2.0- sLORETA and LORETA Z Scores and the Cross-Spectrum 
 The computation of instantaneous Z scores for sLORETA and LORETA is 

different than for the surface EEG.   This is because LORETA produces  three 

orthogonal  3-dimensional current vectors from each voxel.   That is, there are three 

time series in the x, y & z directions.   The resultant vector is the square root of the sum 

of squares.   A problem with the resultant vector is that the square of x, y & z rectifies 

the EEG current source time series or produces only positive values which doubles the 

frequency of the time series.   In order to avoid frequency doubling ANI computes the 

mean time series or (∑x + y + z)/3 = mean current source in each voxel.   ANI also 

computes the x, y & Z mean and standard deviation and compared the average of the 

means to the average of the x, y & z vectors and found that they are essentially the 

same.  Transforms were then applied to the average current source instantaneous time 

series in order to obtain Gaussian mean and standard deviation current sources from 

each voxel.  

 The mathematical details of using or not using complex numbers must be 

described and the methods of computation at each step.   The case of the Neuroguide 

instantaneous norms the cross-spectrum is calculated in the x, y & z directions.   The Z 

scores are computed from the mean of the x, y & z real and imaginary components and 

the resultant vector is not used in the calculation of coherence and phase differences.    

The 1
st
 and 2

nd
 derivatives of the phase difference time series is used to compute phase 

shift and phase lock duration with the same mathematics and methods as described by 

(Thatcher et al, 2008; 2009).   The resultant vector is useful for co-modulation or 

covariant magnitudes between Brodmann areas computed by a correlation coefficient. 

 

2.1 – Network Nodes and Connections 

 The 3D spatial Laplacian operator maximally smoothes the current source space 

in alignment with the physiological constraint of simultaneously active neurons that 

generate a spatially smeared distribution of current densities (see Pascual-Marqui, 

1999).   This means that adjacent voxels will be positively correlated and decrease 

smoothly with distance and as a consequence the center voxel of any given functional 

node will be representative of that node.   For example, the correlation between the 

center voxel of a Brodmannn area and an adjacent voxel is about 0.99 and the 

correlation at the boundary or edge voxel is about 0.85 which is the case for all center 

voxels.   Also, computing 6,230 combinatorial is a matrix of 19 million by 19 million in 

the complex domain which is not feasible to compute in real-time.   As a consequence 

an accepted method of computing sLORETA coherence and phase of the EEG sources 
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is by using the center voxel of each functional region of interest or Brodmann area or 

node of an inter-connected network (Langer et al, 2011).  The cross-spectrum is then 

calculated for all combinations of 88 Brodmann areas (N = 3,828) for each frequency 

band which is handled easily with today’s computers in real-time. 

  

3.0 – Z Tunes for Individualized EEG Biofeedback Protocols 

A fourth and intertwined clinical concept in the design of Z score biofeedback is 

“individualized” EEG biofeedback and non-protocol driven EEG biofeedback.   The 

idea of linking patient symptoms and complaints to functional localization in the brain 

and resonant frequencies of the EEG as evidenced by “de-regulation” of neural 

populations is fundamental to individualized biofeedback.   For example, de-regulation 

is recognized by significantly elevated or reduced power or network measures such as 

coherence and phase within regions of the brain that sub-serve particular functions that 

can be linked to the patient’s symptoms and complaints.    The use of Z scores for 

biofeedback is designed to “re-regulate” or “optimize” the homeostasis, neural 

excitability and network connectivity in particular regions of the brain.  The functional 

localization and linkage to symptoms is based on modern knowledge of brain function 

as measured by fMRI, PET, penetrating head wounds, strokes and other neurological 

evidence acquired over the last two centuries (see Heilman and Valenstein, 1993; 

Braxis et al, 2007 see the Human Brain Mapping database of functional localization at:  

http://hendrix.imm.dtu.dk/services/jerne/brede/index_ext_roots.html).   Thus, the false 

concern that Z score biofeedback will make exceptional people dull and an average 

individual a genius is misplaced.  The concept is to reinforce stability and not periods 

of “chaos” in networks linked symptoms and complaints and then monitor 

improvement or symptom reduction during the course of treatment using a single 

metric for all measures, i.e., the Z score.  For peak performance applications, a careful 

inventory of the client’s personality style, self assessment of weaknesses and strengths 

and identification of the client’s specific areas that he/she wishes to improve must be 

obtained before application of Z score biofeedback.   Then, the practitioner attempts to 

link the client’s identification of areas of weakness that he/she wants improved to 

functional localization as expressed by “de-regulation” of deviant neural activity that 

may be subject to change.   

As mentioned previously, the instantaneous Z scores are much smaller than the 

FFT Z scores in NeuroGuide
TM

 which uses the same subjects for the normative 

database.    Smaller Z scores when using the instantaneous Z scores is expected because 

of the necessary inclusion of the moment-to-moment within session variance.   One 

should not be surprised by a 50% reduction in JTFA Z scores in comparison to FFT Z 

scores and this is why it is best to first use 19 channel EEG measures and the highly 

stable FFT Z scores to link symptoms to functional localization in the brain to the 

extent possible.   Then use the Z Score program inside of NeuroGuide
TM

 to evaluate the 

patient’s instantaneous Z scores in preparation before the biofeedback procedure 

begins.   This will allow one to obtain a unique picture of the EEG instantaneous Z 

scores of each unique patient prior to beginning Z score biofeedback.   The clinician 

must be trained to select which Z scores best match the patient’s symptoms and 

complaints.  A general rule is choice of Z scores to use for biofeedback depends on two 

factors obtained using a full 19 channel EEG analysis: 1- scalp location(s) and, 2- 
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magnitude of the Z scores.  De-regulation by hyperpolarization produces slowing in the 

EEG and de-regulation due to reduced inhibition produces deviations at higher 

frequencies.  The direction of the Z score is much less important than the location(s) of 

the deviant Z scores and the linkage to the patient’s symptoms and complaints. 

Here is a step by step description of how to review your patient’s EEG prior to 

designing a Z score biofeedback protocol.   The Z score biofeedback program inside of 

NeuroGuide
TM

 is the same program as used by Advanced Brain Monitoring, 

BrainMaster, Thought Technology, EEG Spectrum, Neurofeld Q20, Mind Media BV 

(NeXus) and Deymed.    

 

3.1 – Step-by-Step Instantaneous Z Score Tutorial inside of NeuroGuide
TM

 

Before beginning the step by step tutorial, please download the free NeuroGuide 

Demo at http://www.appliedneuroscience.com/Contact%20Download1.htm.   Install 

and launch NeuroGuide, accept the copyright agreement and then click Demo.  If one is 

a current user of NeuroGuide
TM

 then rename the file c:/program 

files/NeuroGuide/passKeyB to oldpassKeyB and then launch NeuroGuide and click 

Demo.   

 

Step 1-  Click File Open > Lexicor > Lexicor NRS24.   This is the EEG from a 

55 yr. old male who was struck by a bat near to his right parietal bone 

and suffered a slow bleeding epidural hematoma.   The day following 

the incident the patient was found on the floor and unresponsive and the 

CT scan showed blood had pocketed in the occipital region and drainage 

of the blood in the occipital region was ordered.  Two years post 

incident the patient has spatial neglect, is in a wheel chair due to 

paralysis of his left side and has denial of the extent of his disorder and 

problems recognizing emotions in others.   We expect to find P4 to be 

deviant from normal based on clinical symptoms. 

 

Step 2- In the Subject Information window, for age type 55 and select the eyes 

closed condition and click ok. 

 

Step 3- Double click Linked Ears in the Montage list on the left side of the 

screen. 

 

Step 4- Edit > Select All and then Click View > Dynamic FFT > Absolute 

Power and position the mouse over the Z score of Absolute Power panel 

and depress the left mouse button and move the mouse to 5.5 Hz and 

view the elevated Z scores in C4 and P4.   Select all is not a 

recommended option in NeuroGuide
TM

 because it contains artifact and is 

only used here for illustration purposes.   

 

Step 5- Click View > Dynamic JTFA > Absolute Power 

 

 Step 6- Click View > Dynamic JTFA > Z Scores 
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Step 7- Click View > Dynamic JTFA > Color Maps 

 

Step 8 – Depress the left mouse button and drag the mouse over the EEG 

tracings and view the dynamic Z scores in the delta, theta, alpha, beta 

and hi-beta frequency bands.   Depress the left mouse button and move 

the mouse to the right border and automatically advance the 

instantaneous Z scores like a movie. 

 

Step 9- Change the display time to 1 second (located in the lower left corner) 

and review your patient’s instantaneous Z scores for all 19 locations like 

a temporal zoom lenz. 

 

Figure 6 is an example of the instantaneous Z score screen inside of 

NeuroGuide
TM

 while the instantaneous Z scores are being reviewed. 

 

 
Fig. 6 – Screen capture from NeuroGuide

TM
 in the Demo mode from a patient with right parietal and 

right central injury.   Instantaneous Z scores are on the right, EEG traces are on the left.  Depress the left 

mouse button move the mouse over the traces.   Move the mouse to the right border and watch a movie 

of the dynamic Z scores.  Download the free NeuroGuide
TM

 Demo at www.appliedneuroscience.com 

 

A P4 and C4 theta and delta deviation from normal is evident as well as bilateral 

occipital delta deviations from normal.   There is diminished alpha and theta but in the 

instantaneous Z scores but on the average the dynamic FFT provides a much clearer 

picture of the right parietal and right central Z scores.  For illustration purposes only, a 
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biofeedback protocol would be to reward Z score values less than and greater than 2 

standard deviations in the theta frequency band in P4 and C4 and most of the feedback 

rewards will automatically occur in the delta and theta frequency band.    As mentioned 

previously, the above is an example of an individualized Z score biofeedback procedure 

after reviewing the patent’s EEG using the same instantaneous Z score program 

running in Advanced Brain Monitoring, BrainMaster, Neurofield Q20, Thought 

Technology, EEG Spectrum, Mind Media BV (NeXus) and Deymed.    

 

3.2 - Implementation of the Z Score Biofeedback 

 Step one is to compute means and standard deviations of instantaneous absolute 

power, relative power, power ratios, coherence, phase differences and amplitude 

asymmetries on selected age groups of normal subjects from the 19 channel 10/20 

electrode locations using the within session and between session variance as described 

previously.    The inclusion/exclusion criteria, number of subjects, number of subjects 

per age group, cross-validation procedures and other details of the means and standard 

deviation computations is published (Thatcher et al, 1987; 2003) and shown in Figure 

5.   Step two is to develop a Dynamic Link Library or DLL that can be distributed to 

EEG biofeedback manufacturers such as Advanced Brain Monitoring, BrainMaster, 

EEG Spectrum, Thought Technology, Neurofield Q20, Mind Media BV (NeXus) and 

Deymed which allows the manufacturers to integrate the instantaneous Z scores inside 

of their already existing software environments.     The dll involves only four command 

lines of code and is designed for software developments to easily implement the 

instantaneous Z scores by passing raw digital data to the dll and then organizing the Z 

scores that are returned in less than one microsecond.   This rapid analysis and return of 

Z scores is essential for timely feedback when specific EEG features are measured by 

the Complex Demodulation JTFA operating inside of the dll. 

 

3.3 – JTFA Complex Demodulation Computations 
 The mathematical details of complex demodulation used to compute the 

instantaneous Z scores as contained in the Applied Neuroscience, Inc. “dll” are 

provided in the Appendix section 4.0  and are described in Otnes and Enochson, 1977; 

Granger and Hatanaka, 1964; Bloomfield, 2000; Thatcher et al, 2007).  Complex 

demodulation is a time domain digital method of spectral analysis whereas the fast 

Fourier transform (FFT) is a frequency domain method.  These two methods are related 

by the fact they both involve sines and cosines and both operate in the complex domain 

and in this way represent the same mathematical descriptions of the power spectrum.  

The advantage of complex demodulation is that it is a time domain method and less 

sensitive to artifact and it does not require windowing nor even integers of the power of 

2 as does the FFT.   The FFT integrates power in a frequency band over the entire 

epoch length and requires windowing functions which can dramatically affect the 

power values whereas, as mentioned previously, complex demodulation does not 

require windowing (Otnes and Enochson, 1972).   Complex demodulation was 

computed for the linked ears and eyes open and eyes closed conditions for all 625 

subjects in the normative database.   
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Table I – Time Domain Conversion of  Frequencies to Time of the Z Score 

Biofeedback DLL and NeuroGuide.   The asterisk * = NeuroGuide Only 

 

      Center Frequency          Band Width   Time Domain 

      Delta             2.5 Hz                1 – 4 Hz 1,000 ms to 250 ms 

      Theta             6.0 Hz                4 -  8 Hz 250 ms to 125 ms 

      Alpha             8.0 Hz              8 – 12 Hz 125 ms to 83 ms 

      Beta           18.5 Hz            12 – 25 Hz 83 ms to 40 ms 

      Hi-Beta           27.5 Hz            25 – 30 Hz 40 ms to 33 ms 

      Beta 1           13.5 Hz            12 – 15 Hz 83 ms to 67 ms 

      Beta 2           16.5 Hz            15 – 18 Hz 67 ms to 56 ms 

      Beta 3           21.5 Hz            18 – 25 Hz 56 ms to 40 ms 

     Alpha 1              9.0 Hz              8 – 10 Hz 125 ms to 100 ms 

     Alpha 2            11.0 Hz            10 – 12 Hz 100 ms to 83 ms 

     Gamma 1 *        FFT only            30 – 35 Hz 33 ms to 29 ms 

     Gamma 2 *        FFT only            35 – 40 Hz 29 ms to 25 ms 

     Gamma 3 *        FFT only            40 – 50 Hz 25 ms to 20 ms 

 

 Figure 7 is an illustration of the method of complex demodulation for the 

computation of power, coherence and phase.   The mathematical details are in the 

Appendix, section 4.0. 

 

 
Fig. 7 – Diagram of complex demodulation.  Left is a sine wave as input which is multiplied by the sine 
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and cosine waves at the center frequency of a given frequency band as described in Table I which 

transforms the digital time series to the complex plane.  A 6
th

 order Butterworth low-pass filter is used to 

shift the frequency to zero where power at the center frequency is then calculated using the Pythagorean 

theorem.  Complex numbers are then used to compute coherence and phase as described in Appendix, 

section 4.0.   

 

3.4 - Z Scores and qEEG Normative Databases 

 Matousek and Petersen (1973) computed means and standard deviations in one 

year age groups and were the first to use Z scores to compare an individual to the 

normative database means and standard deviations.   The Z score is an excellent 

statistic defined as the difference between the value from an individual and the mean of 

the population divided by the standard deviation of the population or 
SD

Xx
Z i

−−−−
==== . 

John and colleques expanded on the use of the Z score for clinical evaluation including 

the use of multivariate measures such as the Mahalanobis distance metric.  A direct 

normalization of the Gaussian distribution using Z scores is useful in comparing 

individuals to a QEEG normative database. That is,  the standard score form of the 

Gaussian is where the mean = 0 and standard deviation = 1 or, by substitution into the 

Gaussian equation for a bell shaped curve, then 

2/2

2

1 z
eY

−−−−====
ππππ

 , where Y = Gaussian distribution and the Z score is a deviation in 

standard deviation units measured along the baseline of the Gaussian curve from a 

mean of 0 and a standard deviation = 1 and deviations to the right of the mean being 

positive and those to the left negative.  By substituting different values of Z then 

different values of Y can be calculated.   For example, when Z = 0, Y = 0.3989 or, in 

other words, the height of the curve at the mean of the normal distribution in standard-

score form is given by the number 0.3989.  For purposes of assessing deviation from 

normal, the values of Z above and below the mean, which include 95% of the area of 

the Gaussian is often used as a level of confidence necessary to minimize Type I and 

Type II errors.   The standard-score equation is also used to cross-validate a normative 

database which again emphasizes the importance of approximation to a Gaussian for 

any normative QEEG database. 

 

3.5 – Standardization by Amplifier Matching and qEEG Normative Databases 

 Surprisingly, matching of amplifier frequency characteristics as a standard was 

largely neglected during much of the history of qEEG normative databases.   E. Roy 

John and colleagues (1982 to 1988) formed a consortium of universities and medical 

schools that were using qEEG who met several times over a few years and was one of 

the supporters of the edited volume by John titled “Machinery of the Mind” (John, 

1990).   One of the important issues consistently raised at the consortium meetings was 

the need for “standardization”.   In the 1980s it was technically difficult to match 

different EEG systems because of the infantile development of analysis software.   This 

history forced most qEEG uses to use relative power because absolute power was not 

comparable between different EEG machines.   There was no frequency response 

standardization between different EEG machines and thus there was no cross-platform 

standardization of qEEG.   It was not until the mid 1990s that computer speed and 
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software development made amplifier matching and normative database amplifier 

equilibration a possibility.   The first use of standardized matching of amplifiers was to 

the University of Maryland (UM) database (Thatcher et al, 2003).   The procedure 

involved injecting micro volt calibration sign waves into the input of amplifiers of 

different EEG machines and then inject the same micro volt signals into the normative 

database amplifiers thus obtaining two frequency response curves.   Equilibration of a 

normative qEEG database to different EEG machines is the ratio of the frequency 

response curves of the two amplifiers that are then used as coefficients in the power 

spectral analysis.   This was an important step because suddenly absolute power Z 

scores and normative database comparisons became possible.   The frequencies in 

absolute power are independent of each other and are not distorted.   It is always best to 

use absolute values when ever possible and not relative values or even ratios.   A ratio 

can change due to the denominator or the numerator and one can not determine which 

has changed without evaluating the absolute values used to compute the ratios. 

As illustrated in Figure 8, a simple method of amplifier equilibration to exactly 

match the frequency characteristics of different amplifiers is to calibrate the amplifiers 

using micro-volt sine waves at discrete frequencies from 1 to 40 Hz and injecting the 

sine waves into the inputs of the EEG amplifiers.   Then take the ratio of the micro-volt 

values at each frequency and use the ratios to exactly equate the spectral output values 

at different frequencies for different amplifiers.  This method creates a universal 

equilibration process so that micro-volts in a given amplifier are equal to micro-volts in 

all other amplifiers including the normative database amplifiers.   By equilibrating 

amplifiers then direct comparisons between a given patient’s EEG and the normative 

database means and standard deviations is valid and meaningful.    
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Fig. 8 – Flow chart of the amplifier standardization procedure.  Micro volt sine waves are injected into the 

input of amplifiers and the frequency responses are calculated.  The frequency response of the normative 

database amplifiers and the frequency response of other EEG amplifier systems are then equated and the 

spectral analysis is adjusted so that there is a standardized import and matching of amplifier systems with 

the common unit being micro volts (uV).  

 

 

4.0 - General Method to Produce a Valid Instantaneous Z Score EEG Database 

 Figure 9 is an illustration of a step by step procedure by which the Z 

instantaneous score normative EEG database was validated and sensitivities calculated.   

The left side of the figure is the edited and artifact clean and reliable digital EEG time 

series which may be re-referenced or re-Montaged, which is then analyzed in either the  

time domain or the frequency domain.  
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Fig. 9- Illustration of the step by step procedure to Gaussian cross-validate and then validate by 

correlations with clinical measures in order to estimate the predictive and content validity of any EEG 

normative database. The feedback connections between Gaussian cross validation and the means and 

standard deviations refers to transforms to approximate Gaussian if the non-transformed data is less 

Gaussian.  The clinical correlation and validation arrow to the montage stage represents repetition of 

clinical validation to a different montage or reference or condition such as eyes-open, active tasks, eyes-

closed, etc. to the adjustments and understanding of the experimental design(s). From Thatcher et al, 

2003. 

 

4.1 – Age Groupings of the Instantaneous Z Score Normative Population  

 The selected normal subjects are grouped by age with sufficiently large sample 

size and the means and standard deviations of the EEG time series and/or Frequency 

domain analyses are computed for each age group.   Transforms are applied to 

approximate a Gaussian distribution of the EEG measures that comprise the means.   

Once approximation to Gaussian is completed, then Z scores are computed for each 

subject in the database and leave one out Gaussian Cross-Validation is computed in 

order to arrive at an optimum Gaussian Cross-validation sensitivity.    Finally the 

Gaussian validated norms are subjected to content and predictive validation procedures 

such as correlation with Neuropsychological test scores and intelligence, etc. and also 

discriminant analyses and neural networks and outcome statistics, etc.   The content 

validations are with respect to clinical measures such as intelligence, 

neuropsychological test scores, school achievement, clinical outcomes, etc.  The 

predictive validations are with respect to the discriminative, statistical or neural 

network clinical classification accuracy.  Both parametric and non-parametric statistics 

are used to determine the content and predictive validity of a normative EEG database.. 

 Figure 10 shows the number of subjects per year in the normative EEG lifespan 
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database.  It can be seen that the largest number of subjects are in the younger ages 

(e.g., 1 to 14 years, N = 470) when the EEG is changing most rapidly.  As mentioned 

 

 
Fig. 10 - The NeuroGuide and the Z Tunes are the same and the total number of 

subjects = 727 in the Z score Lifespan EEG reference normative database. The database 

is a “life-span” database with the two months of age being the youngest subject and 

82.3 years of age being the oldest subject. Two year means were computed using a 

sliding average with 6 month overlap of subjects.   This produced a more stable and 

higher age resolution normative database and a total of 22 different age groups.   The 

22 age groups and age ranges and number of subjects per age group is shown in the bar 

graph. 

 

previously, a proportionately smaller number of subjects represents the adult age range 

from 14 to 82 years (N = 208).   The Z score normative database includes a total of 727 

carefully screened individual subjects ranging in age from 2 months to 82 years.      In 

order to increase the time resolution of age, sliding averages were used for the 

stratification in NeuroGuide
TM

 and for instantaneous Z scores (Thatcher et al, 

2003).  Two year means were computed using a sliding average with 6 month overlap 

of subjects.   This produced a more stable and higher age resolution normative database 

and a total of 22 different age groups.   The 22 age groups and age ranges and number 

of subjects per age group is shown in the bar graph in figure 10. 
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4.2 – Z Tunes
TM

 and Gaussian Weighted Resonance Matching 
 Two important facts should be considered when designing reward feedback 

with real-time Z scores: 1- the neurophysiologic fact that most cortical pyramidal 

neurons behave like “band pass” filters and are tuned to particular center frequencies 

and band widths and, 2- the Z scores are themselves a Gaussian probability distribution.   

The resonant properties of cortical pyramidal neurons are determined by the membrane 

potential, passive cable properties and ionic conductance channels of Na+, K+, Cl+ & 

Ca++ and the shape of the resonance is approximately ‘Gaussian’.    Therefore, the 

optimal biofeedback reward is one that reinforces the probability distribution of Z 

scores from a given patient for a given metric to better approximate the Gaussian 

probability distribution of the normative database.    If one uses a simple window of 

e.g., ± 5 st. dev. without any weighting then a 4.9 st. dev. instantaneous Z score is 

treated the same as a 0.5 st. dev. instantaneous Z score and there is little information 

given to the brain to help shape the Z score probability distribution toward Z = 0.    

Tom Collura at Brainmaster experimented with a percentage control where only a 

percentage of instantaneous Z scores are required to be within a specific range in order 

to receive treatment and this is called “Z%ok”, e.g., 70%.   The criticism of this method 

is that outliers will also be reinforced and this should slow the rate of shaping the Z 

scores toward Z = 0.    

 A more complicated but a more direct method than Z%ok is the method that we 

refer to as “Z Tune” that is to calculate the slope of a 10 seconds history of Z scores and 

allow reinforcement to occur if outliers are moving in the direction of Z = 0.   This is a 

type of adaptive filter designed to take advantage of the probability and Gaussian nature 

of neurons by weighting extreme or outlier instantaneous Z score by a probability of 

moving in the direction of Z = 0.  In this way the most frequent events that approximate 

the center frequency and band width of cortical resonance in normal subjects is 

reinforced and the influence of outliers are minimized by lower weightings.   Outliers 

are not ignored, they are reinforced when moving in the direction of greater stability 

and less “chaos”.    In other words, by using an adaptive real-time resonance slope then 

instantaneous Z scores that move toward the most probable state are reinforced more 

than events that move in the opposite direction or away from the most probable 

normative resonance.      
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6.0 - Appendix - 

 

Complex Demodulation and Joint-Time-Frequency-Analysis 

 Complex demodulation is used in a joint-time-frequency-analysis (JTFA) to compute 

instantaneous power, coherence, amplitude asymmetry and phase-differences (Granger and 

Hatanaka, 1964; Otnes and Enochson, 1978; Bloomfield, 2000; Thatcher et al, 2007) and then 

to compute a Z score based on these instantaneous values.   Complex demodulation is an 

analytic linear shift-invariant transform that first multiplies a time series by the complex 

function of a sine and cosine at a specific center frequency (see Table I) followed by a low pass 

filter (6
th

 order low-pass Butterworth) which removes all but very low frequencies (shifts 

frequency to 0) and transforms the time series into instantaneous amplitude and phase and an 

“instantaneous” spectrum (Bloomfield, 2000).  We place quotations around the term 

“instantaneous” to emphasize that, as with the Hilbert transform, there is always a trade-off 

between time resolution and frequency resolution.    The broader the band width the higher the 

time resolution but the lower the frequency resolution and vice versa.  Mathematically, 

complex demodulation is defined as an analytic transform that involves the multiplication of a 

discrete time series {xt, t = 1, . . . , n} by sine ω0t and cos ω0t giving 
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and then apply a low pass filter F to produce the instantaneous time series, Zt’ and Zt’’ where 

the sine and cosine time series are defined as: 
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and 
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is an estimate of the instantaneous phase at time t.   At this step the complex demodulation 

transform is the same as the Hilbert transform (Pikovsky et al, 2003, p. 362; Oppenheim and 

Schaefer, 1975). 

 The instantaneous cross-spectrum is computed when there are two time series {yt, t = 1, 
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The instantaneous cross-spectrum is 
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and the instantaneous coherence is 
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The instantaneous phase-difference is 
tt

ϕϕϕϕϕϕϕϕ ′′′′−−−− .  That is, the instantaneous phase difference is 

computed by estimating the instantaneous phase for each time series separately and then taking 

the difference.   Instantaneous phase difference is also the arctangent of the imaginary part of 

Vt divided by the real part (or the instantaneous quadspectrum divided by the instantaneous 

cospectrum) at each time point. 

 


